Renan Roggia

Reading notes

Highlights and summaries from the books and articles I have read.

A Philosophy of Software Design

A Philosophy of Software Design

en-US

Reading
You Dont know JS - this & Object Prototypes

You Dont know JS - this & Object Prototypes

en-US, 2022-12-26

Reading
Enterprise Integration Patterns

Enterprise Integration Patterns

Designing, Building, and Deploying Messaging Solutions

en-US, 2022-12-25

Planning
Mathematical Structure for Computer Science

Mathematical Structure for Computer Science

en-US, 2022-08-29

Reading
RFC7636 -  Proof Key for Code Exchange by OAuth Public Clients

RFC7636 - Proof Key for Code Exchange by OAuth Public Clients

en-US, 2022-07-17

Read
Financial-grade API: JWT Secured Authorization Response Mode for OAuth 2.0 (JARM)

Financial-grade API: JWT Secured Authorization Response Mode for OAuth 2.0 (JARM)

en-US, 2022-07-08

Read
Financial-grade API Security Profile 1.0 - Part 2: Advanced

Financial-grade API Security Profile 1.0 - Part 2: Advanced

en-US, 2022-07-07

Read
Financial-grade API Security Profile 1.0 - Part 1: Baseline

Financial-grade API Security Profile 1.0 - Part 1: Baseline

en-US, 2022-07-07

Read
The Kubernetes Book - 2019 edition

The Kubernetes Book - 2019 edition

en-US, 2022-07-06

Planning
The Kubernetes Book - 2021 edition

The Kubernetes Book - 2021 edition

en-US, 2022-07-06

Planning
Camel In Action

Camel In Action

en-US, 2022-07-05

Reading
0Auth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access Tokens

0Auth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access Tokens

en-US, 2022-07-011

Planning
Algorithms

Algorithms

en-US, 2022-05-09

Reading
The DevOPS Handbook: How to Create World-Class Agility, Reliability, and Security in Technology Organizations

The DevOPS Handbook: How to Create World-Class Agility, Reliability, and Security in Technology Organizations

en-US, 2022-03-22

Planning
Measure What Matters

Measure What Matters

en-US, 2022-03-14

Reading
Continuous Discovery Habits

Continuous Discovery Habits

Discover Products that Create Customer Value and Business Value

en-US, 2021-09-13

Planning
Kanban in action

Kanban in action

en-US, 2021-08-29

Planning
Extreme Programming Explained

Extreme Programming Explained

Embrace Change

en-US, 2021-06-20

Read
Site Reliability Engineering

Site Reliability Engineering

en-US, 2021-05-07

Planning
Microservices Patterns

Microservices Patterns

en-US, 2021-05-04

Planning
Domain Driven Design

Domain Driven Design

Atacando as Complexidades no Coração do Software

pt-BR, 2021-04-04

Planning
Accelerate

Accelerate

Building and Scaling High Performing Technology Organizations

en-US, 2021-03-25

Read
Refactoring 2nd edition - Improving the design of existing code

Refactoring 2nd edition - Improving the design of existing code

en-US, 2021-03-16

Read
You Dont know JS - Get Started

You Dont know JS - Get Started

en-US, 2021-01-01

Read
You Dont know JS - Scope & Closures

You Dont know JS - Scope & Closures

en-US, 2021-01-01

Read
Arquitetura Limpa

Arquitetura Limpa

O Guia do Artesão para Estrutura e Design de Software

pt-BR, 2021-01-01

Planning
Running Serverless

Running Serverless

en-US, 2021-01-01

Planning
Agile estimating and planning

Agile estimating and planning

en-US, 2020-03-01

Read
Phoenix Project

Phoenix Project

en-US, 2020-02-01

Read
Scrum

Scrum

A arte de fazer o dobro do trabalho na metade do tempo

pt-BR, 2020-01-01

Read
RFC6749 - The OAuth 2.0 Authorization Framework

RFC6749 - The OAuth 2.0 Authorization Framework

en-US, 2018-06-01

Read
RFC7521 - Assertion Framework for OAuth 2.0 Client Authentication and Authorization Grants

RFC7521 - Assertion Framework for OAuth 2.0 Client Authentication and Authorization Grants

en-US, 2018-06-01

Read
RFC7522 - Security Assertion Markup Language (SAML) 2.0 Profile for OAuth 2.0 Client Authentication and Authorization Grants

RFC7522 - Security Assertion Markup Language (SAML) 2.0 Profile for OAuth 2.0 Client Authentication and Authorization Grants

en-US, 2018-06-01

Read
Agile Testing

Agile Testing

A practical guide for testers and agile teams

en-US, 2015-06-01

Read