Renan Roggia

Bookshelf

Backlog 23

A arte da Gestão

A arte da Gestão

Um Guia Prático para Integrar Lideranças e Recursos Humanos no Setor de Tecnologia

pt-BR

Banco de Dados

Banco de Dados

Teoria e Desenvolvimento

pt-BR

Como ser um programador melhor

Como ser um programador melhor

Um manual para programadores que se importam com código

pt-BR

Da estratégia ágil aos resultados

Da estratégia ágil aos resultados

Uma combinação de abordagens adaptativas, mudanças dialógicas e gestão avançada de projetos

pt-BR

Design Patterns com Java

Design Patterns com Java

Projeto Orientado a Objetos Guiado por Padrões

pt-BR

DevOps

DevOps

Na prática: entrega de software confiável e automatizada

pt-BR

Efficient Learning Machines

Efficient Learning Machines

Theory, concepts, and applications for engineers and system designers

en-US

Estatistica

Estatistica

O que é, para que serve e como funciona

pt-BR

Introdução à arquitetura e design de software

Introdução à arquitetura e design de software

Uma visão sobre a plataforma java

pt-BR

Java Concurrency In Practice

Java Concurrency In Practice

en-US

Lean Inception

Lean Inception

Como alinhar pessoas e construir o produto certo

pt-BR

Linux a Bíblia

Linux a Bíblia

O mais abrangente e definitivo guia sobre linux

pt-BR

Introdução ao teste de software

Introdução ao teste de software

pt-BR

MEAN Definitivo

MEAN Definitivo

com Mongo, Express, Angular e Node

pt-BR

Microsserviços prontos para a produção

Microsserviços prontos para a produção

Construindo sistemas padronizados em uma organização de engenharia de software

pt-BR

Monolith to Microservices

Monolith to Microservices

Evolutionary Patterns to transform your monolith

en-US

Management 3.0

Management 3.0

Leading Agile Developers, Developing Agile Leaders

en-US

Data Science do Zero

Data Science do Zero

Primeiras regras com o python

pt-BR

Qualidade de Software

Qualidade de Software

pt-BR

Manual de DevOps

Manual de DevOps

Como obter agilidade, confiabilidade e segurança em organizações tecnológicas

pt-BR

Trabalho eficaz com código legado

Trabalho eficaz com código legado

pt-BR

Treinamento de equipes ageis

Treinamento de equipes ageis

pt-BR

Unlocking Agility

Unlocking Agility

en-US

Planning 18

Implementando o desenvolvimento Lean de Software

Implementando o desenvolvimento Lean de Software

Do conceito ao dinheiro

pt-BR

Padrões de Projeto: soluções reutilizáveis de software orientado a objetos

Padrões de Projeto: soluções reutilizáveis de software orientado a objetos

pt-BR

TDD - Desenvolvimento Guiado por Testes

TDD - Desenvolvimento Guiado por Testes

pt-BR

Enterprise Integration Patterns

Enterprise Integration Patterns

Designing, Building, and Deploying Messaging Solutions

en-US, 2022-12-25

Read my notes
The Kubernetes Book - 2019 edition

The Kubernetes Book - 2019 edition

en-US, 2022-07-06

Read my notes
The Kubernetes Book - 2021 edition

The Kubernetes Book - 2021 edition

en-US, 2022-07-06

Read my notes
0Auth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access Tokens

0Auth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access Tokens

en-US, 2022-07-011

Read my notes
The DevOPS Handbook: How to Create World-Class Agility, Reliability, and Security in Technology Organizations

The DevOPS Handbook: How to Create World-Class Agility, Reliability, and Security in Technology Organizations

en-US, 2022-03-22

Read my notes
Creating a Software Engineering Culture

Creating a Software Engineering Culture

en-US, 2022-01-01

Entendendo Algoritmos

Entendendo Algoritmos

Um guia ilustrado para programadores e outros curiosos

pt-BR, 2022-01-01

Continuous Discovery Habits

Continuous Discovery Habits

Discover Products that Create Customer Value and Business Value

en-US, 2021-09-13

Read my notes
Kanban in action

Kanban in action

en-US, 2021-08-29

Read my notes
Team Topologies

Team Topologies

en-US, 2021-06-21

Site Reliability Engineering

Site Reliability Engineering

en-US, 2021-05-07

Read my notes
Microservices Patterns

Microservices Patterns

en-US, 2021-05-04

Read my notes
Domain Driven Design

Domain Driven Design

Atacando as Complexidades no Coração do Software

pt-BR, 2021-04-04

Read my notes
Arquitetura Limpa

Arquitetura Limpa

O Guia do Artesão para Estrutura e Design de Software

pt-BR, 2021-01-01

Read my notes
Running Serverless

Running Serverless

en-US, 2021-01-01

Read my notes

Reading 9

A Philosophy of Software Design

A Philosophy of Software Design

en-US

Read my notes
O Mitico homem-mes

O Mitico homem-mes

pt-BR

You Dont know JS - this & Object Prototypes

You Dont know JS - this & Object Prototypes

en-US, 2022-12-26

Read my notes
Mathematical Structure for Computer Science

Mathematical Structure for Computer Science

en-US, 2022-08-29

Read my notes
Camel In Action

Camel In Action

en-US, 2022-07-05

Read my notes
Algorithms

Algorithms

en-US, 2022-05-09

Read my notes
Measure What Matters

Measure What Matters

en-US, 2022-03-14

Read my notes
A Regra é não ter Regras

A Regra é não ter Regras

A Netflix e a cultura da reinvenção

pt-BR, 2022-01-01

Desenvolvimento ágil limpo

Desenvolvimento ágil limpo

De volta às origens

pt-BR, 2022-01-01

Read 26

O Sistema toyota de proução

O Sistema toyota de proução

pt-BR

RFC7636 -  Proof Key for Code Exchange by OAuth Public Clients

RFC7636 - Proof Key for Code Exchange by OAuth Public Clients

en-US, 2022-07-17

Read my notes
Financial-grade API: JWT Secured Authorization Response Mode for OAuth 2.0 (JARM)

Financial-grade API: JWT Secured Authorization Response Mode for OAuth 2.0 (JARM)

en-US, 2022-07-08

Read my notes
Financial-grade API Security Profile 1.0 - Part 2: Advanced

Financial-grade API Security Profile 1.0 - Part 2: Advanced

en-US, 2022-07-07

Read my notes
Financial-grade API Security Profile 1.0 - Part 1: Baseline

Financial-grade API Security Profile 1.0 - Part 1: Baseline

en-US, 2022-07-07

Read my notes
Ágil do jeito certo

Ágil do jeito certo

Transformação sem caos

pt-BR, 2021-08-25

Extreme Programming Explained

Extreme Programming Explained

Embrace Change

en-US, 2021-06-20

Read my notes
Accelerate

Accelerate

Building and Scaling High Performing Technology Organizations

en-US, 2021-03-25

Read my notes
Refactoring 2nd edition - Improving the design of existing code

Refactoring 2nd edition - Improving the design of existing code

en-US, 2021-03-16

Read my notes
You Dont know JS - Get Started

You Dont know JS - Get Started

en-US, 2021-01-01

Read my notes
You Dont know JS - Scope & Closures

You Dont know JS - Scope & Closures

en-US, 2021-01-01

Read my notes
A Startup Enxuta

A Startup Enxuta

Como usar a inovação contínua para criar negócios radicalmente bem-sucedidos

pt-BR, 2021-01-01

Scrum guide

Scrum guide

en-US, 2021-01-01

Agile estimating and planning

Agile estimating and planning

en-US, 2020-03-01

Read my notes
Phoenix Project

Phoenix Project

en-US, 2020-02-01

Read my notes
Scrum

Scrum

A arte de fazer o dobro do trabalho na metade do tempo

pt-BR, 2020-01-01

Read my notes
The pragmatic programmer

The pragmatic programmer

en-US, 2020-01-01

Effective Java

Effective Java

Best practices for the Java Platform

en-US, 2019-01-01

RFC6749 - The OAuth 2.0 Authorization Framework

RFC6749 - The OAuth 2.0 Authorization Framework

en-US, 2018-06-01

Read my notes
RFC7521 - Assertion Framework for OAuth 2.0 Client Authentication and Authorization Grants

RFC7521 - Assertion Framework for OAuth 2.0 Client Authentication and Authorization Grants

en-US, 2018-06-01

Read my notes
RFC7522 - Security Assertion Markup Language (SAML) 2.0 Profile for OAuth 2.0 Client Authentication and Authorization Grants

RFC7522 - Security Assertion Markup Language (SAML) 2.0 Profile for OAuth 2.0 Client Authentication and Authorization Grants

en-US, 2018-06-01

Read my notes
Código Limpo

Código Limpo

Habilidades Práticas do Agile Software

pt-BR, 2018-01-01

Bridging the Communication Gap

Bridging the Communication Gap

Specification by Example and Agile Acceptance Testing

en-US, 2016-05-01

Fifty Quick Ideas to Improve Your Tests

Fifty Quick Ideas to Improve Your Tests

en-US, 2016-01-01

Continuous Integration

Continuous Integration

Improving Software Quality and Reducing Risk

en-US, 2015-12-16

Agile Testing

Agile Testing

A practical guide for testers and agile teams

en-US, 2015-06-01

Read my notes